Jump to content

Amulet of Mara - Book of Love HELP!

* * * * *

Best Answer Clarke , April 01, 2012 - 02:00 AM

I just realized I ran into this same exact problem too and wanted to see if anyone had an answer. Looks like not. So what I'm gonna have to do is drop all of my gear off at my house, commit a small crime, and have the guards confiscate all of my stolen goods, so I can be rid of that annoying "stolen" Amulet of Mara that is stacked on top. Gah, how retarded is that? And I just tried pulling out 30 Giant Toes and 30 Wheat I had to start leveling up my alchemy, only to notice that it wouldn't let me even USE ANY TOES for alchemy combinations since ONE is needed for some random quest. And now it won't even let me store them again until I complete that one quest! Come on Bethesda. Fix this retardedness. :-) Go to the full post »


  • Please log in to reply
16 replies to this topic

#16
johninman

johninman
  • Guest
I have 8 amulets ive went to jail ive cycled through and ive payed several bounties to try to get it to work. Idk what to do and its severely frustrating

Remove Advertisements Create Account

#17
Inutuangugamail

Inutuangugamail
  • Guest
Well that mission made my heart jump a few beats. Best love story I ever heard from any game




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

This site is not affiliated with ZeniMax Media Inc. or any of its subsidiaries.